MediaWiki/Migration de 1.27.3 vers 1.36.2

De Kono Phil Ceci est la tagline
Aller à la navigation Aller à la recherche

La migration de MediaWiki de la version 1.27.3 vers la version 1.36.2.

Prérequis

La version de MediaWiki à migrée est 1.27.3 :

  • MediaWiki : 1.27.3
  • PHP : 7.0.20
  • MySQL : 5.7.18

La version cible est MediaWiki 1.36.2 :

  • MediaWiki : 1.36.2
  • PHP : 7.3.19+
  • MySQL : 5.5.8+

Etapes

Etapes de migration
Outil Serveur de départ Etape 2 Etape 2 Etape 3 Serveur de destination Observation
MediaWiki 1.27.3 1.27.3 1.31.16 1.36.2 1.36.2 PHPMyAdmin vers 4.5.4.1 fonctionne
PHP 7.0.20 7.0.32 7.0.x
7.3.19+
7.4.24 7.4.15 PHPMyAdmin vers 4.5.4.1 fonctionne
MySQL 5.7.18 5.5.8+ 5.5.8+ 5.5.8+ 8.0.23 PHPMyAdmin vers 4.5.4.1 ne fonctionne pas

Outil

Utiliser l'outil UwAmp pour effectuer les différentes étapes de migration.

phpMyAdmin :

PHP

PHP version 7.0.32 :

PHP version 7.3.32 :

PHP version 7.4.24 :

Visual C++ Redistribuable

Voir aussi